You can skip this in seconds

Click here to continue

Icecream Ebook Reader 4.35

What's Required in Version 4.35 of Icecream Ebook Reader

1.33Ghz Intel®, AMD or any other compatible processor / faster processor for netbooks; 512MB of RAM

What's New in Version 4.35 of Icecream Ebook Reader

- Library cache actions fixed and improved;
- Other minor fixes.

Look for Similar Items by Category

Educational Software > E-book Software
This product is also listed in: Miscellaneous

Feedback

Popular Downloads